Call Us: (+62).817.410.4747
Log in Register

Login to your account

Username *
Password *
Remember Me

Create an account

Fields marked with an asterisk (*) are required.
Name *
Username *
Password *
Verify password *
Email *
Verify email *
Captcha *

Script auto-update DDNS no-ip.com pada mikrotik

Jika router mikrotik mendapat IP Address Public Dynamic maka, berikut ini adalah script untuk update ip via no-ip.com pertama-tama, tentu saja daftar di http://www.no-ip.com

  1. Registrasi seperti biasa, isi first name, last name, email, username, password, dll. (yang di bold harap diperhatikan)
  2. Setelah registrasi selesai, login dengan username dan password,.
  3. Pilih Hosts/Redirects, lanjut dengan pilih Add Host
  4. Isikan nama hostname dan pilih domain nya. (lagi-lagi yang di bold harap diperhatikan)
  5. IP Address diisikan : 127.0.0.1
  6. Setelah itu klik Create Host pada bagian bawah form.
  7. Pembuatan hostname selesai. Tunggu satu menit untuk diupdate. Sementara itu kita buat scriptnya.

Name: sch-ddns-NoIP
Start Date: Jan/01/1970
Start Time: startup 
Interval : 00:05:00 # tiap lima menit

Isikan on-event script berikut: ubah yang parameter yang berada pada [..] dengan username, password, dan hostname lengkap dengan domainnya di no-ip (mis. katyarina.zapto.org) username, password, dan hostname terdapat pada bagian yang di bold di tutorial registrasi di atas.

 
# DNS no-ip automatic DNS updates 
# Informasi account di no-ip.com 
:global usernoip "[username]" 
:global passnoip "[password]" 
:global hostnamenoip "[domain-no-ip]" 
# Edit variabel selesai di sini 

:global previousIP 

# Print di log untuk debug 
:log info "DNSNoIP: Updating dynamic IP on DNS for host $hostnamenoip" 
:log info "DNSNoIP: Pass $passnoip" 
:log info "DNSNoIP: Last IP $previousIP" 
# mendapatkan IP public di intenet, bisa juga 
# dengan script PHP jika punya hosting support PHP 
/tool fetch url="http://checkip.dyndns.org/" dst-path="/ddnsnoip.html" 
:local hasil [/file get ddnsnoip.html contents]
# Edit untuk mendapatkan IP terbaru :local hasilLen [:len $hasil] :local startLoc [:find $hasil ": " -1]
:set startLoc ($startLoc + 2) :local endLoc [:find $hasil "</body>" -1]
:global currentIP [:pick $hasil $startLoc $endLoc] :log info "DNSNoIP: IP sekarang $currentIP"
# persiapan update :local str "nic/update?hostname=$hostnamenoip&myip=$currentIP"
:if ($currentIP != $previousIP) do={
:log info "DNSNoIP: Dibutuhkan Update"
:set previousIP $currentIP
:log info "DNSNoIP: Kirim Update $currentIP"
:log info [:put [/tool fetch user="$usernoip" password="$passnoip" \
url="http://dynupdate.no-ip.com/$str" dst-path="/$hostnamenoip"]]
:log info "DNSNoIP: Host $hostnamenoip telah terupdate di DNSNoIP dengan IP $currentIP"
} else={
:log info "DNSNoIP: IP sebelumnya $previousIP dan \
IP sekarang $currentIP sama, tidak dibutuhkan update" }

cara panggil router dari internet tinggal isikan hostname pada winbox (connect to..)

Read 10102 times Last modified on 21 Jan 2014, 1:41 PM
Tidar Tanjung

I'm a routing engineer. Trust me, I will show the best path for you.

6 comments

  • Comment Link irfan 25 Jan 2017, 12:34 PM posted by irfan

    schedule nya mana?
    refresh ddns nya bgmn?

  • Comment Link lihuai 02 Apr 2016, 1:49 PM posted by lihuai

    setelah saya coba cm bisa dalam 1 jaringan, kalo beda jaringan/internet lain g bs gan.! caranya gmn y gan?? thx b4

  • Comment Link lihuai 02 Apr 2016, 1:49 PM posted by lihuai

    setelah saya coba cm bisa dalam 1 jaringan, kalo beda jaringan/internet lain g bs gan.! caranya gmn y gan?? thx b4

  • Comment Link Edi 03 Dec 2014, 9:30 AM posted by Edi

    Setelah muter2 d google akhirnya ketemu juga Script yg bekerja. ( 2x Modem ADSL --> Load Bounding Linksys --> Mikrotik ). Trimakasih atas Script nya.

  • Comment Link someone 31 May 2014, 5:02 PM posted by someone

    apakah script ini jalan pada v6?

  • Comment Link someone 31 May 2014, 5:01 PM posted by someone

    apakah script ini jalan pada v6?

Leave a comment

Make sure you enter all the required information, indicated by an asterisk (*). HTML code is not allowed.

Positive SSL