Call Us: (+62).817.410.4747
Log in Register

Login to your account

Username *
Password *
Remember Me

Create an account

Fields marked with an asterisk (*) are required.
Name *
Username *
Password *
Verify password *
Email *
Verify email *
Captcha *

6 queue simple untuk game, browsing, donwload

Pada tutorial kali ini akan dijabarkan minimalis setting untuk bandwidth management pada jaringan warnet yang melayani game online, download, dan browsing. 

  • 1 queue untuk upload
  • 1 queue untuk totail download
  • 1 queue untuk game dengan parent total donwload
  • 1 queue untuk non games sebagai parent untuk paket non-games (download dan browsing), child dari total download
  • 1 queue untuk browsing
  • 1 queue untuk download atau koneksi berat (torrent, dll)

Syarat Jaringan dan Setup

  • latency yang bagus,
  • ping ke server games kisaran 15-85ms,
  • minim rto sebisa mungkin dapat grade A pada Pingtest.net
  • pengetahuan akan torch, untuk tahu port game

Kondisi Jaringan

  • bandwidth down/up 2mbps/512kbps
  • dipakai kurang lebih 25 pc, dengan ip router 192.168.88.1/27,
  • nama interface untuk lan ethernet=ether2 (perhatikan bagian ini karena digunakan di queue simple)
  • alokasi game sekitar 512mbps/128k
  • alokasi non game (browsing, download, streaming) sisanya..
  • menggunakan script nice
  • TANPA proxy
  • tetap menggunakan queue simple
  • tested mikrotik ROS 5.26
  • termasuk game PB, Rohan, AyoDance

script nice (modifikasi dari mikrotik.co.id)

/system scheduler 
add interval=1d name=sch-nice on-event=":if ([:len [/file find name=nice.rsc]]>0) do=\
    {/file remove nice.rsc} ;/tool fetch url=\"http://ixp.mikrotik.co.id/download/nic\
    e.rsc\" ;/import nice.rsc\"" policy=\
    ftp,reboot,read,write,test,winbox,password,sniff,sensitive,api start-date=\
    jan/01/1970 start-time=06:00:00

Mangle

/ip firewall mangle 
add action=mark-connection chain=forward comment="Point Blank" dst-address-list=nice \
    dst-port=39190 new-connection-mark=conn.games protocol=tcp 
add action=mark-connection chain=forward dst-address-list=nice dst-port=40000-40010 \
    new-connection-mark=conn.games protocol=udp 
add action=mark-connection chain=forward comment=Rohan dst-address-list=nice \
    dst-port=22100 new-connection-mark=conn.games protocol=tcp 
add action=mark-connection chain=forward comment="Ayo Dance" dst-address-list=nice \
    dst-port=18901-18910 new-connection-mark=conn.games protocol=tcp 
add action=mark-packet chain=forward connection-mark=conn.games \
    new-packet-mark=pack.games passthrough=no 
add action=mark-connection chain=forward connection-mark=!conn.heavy \
    new-connection-mark=conn.all src-address=192.168.88.0/27 
add action=mark-connection chain=forward connection-bytes=256000-0 \
    connection-mark=conn.all connection-rate=100k-100M \
    new-connection-mark=conn.heavy protocol=tcp 
add action=mark-connection chain=forward connection-bytes=256000-0 \
    connection-mark=conn.all connection-rate=100k-100M \
    new-connection-mark=conn.heavy protocol=udp 
add action=mark-packet chain=forward connection-mark=conn.all \
    new-packet-mark=pack.all passthrough=no 
add action=mark-packet chain=forward connection-mark=conn.heavy \
    new-packet-mark=pack.heavy passthrough=no

Queue type

/queue type 
add kind=pcq name=q.ty.upload pcq-burst-rate=256k pcq-burst-threshold=128k \
    pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=96k \
    pcq-src-address6-mask=64 
add kind=pcq name=q.ty.heavy pcq-burst-rate=512k pcq-burst-threshold=384k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \ 
pcq-rate=256k pcq-src-address6-mask=64 add kind=pcq name=q.ty.game \ pcq-burst-rate=384k pcq-burst-threshold=256k pcq-burst-time=16s pcq \ classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=128k \ pcq-src-address6-mask=64 add kind=pcq name=q.ty.all pcq-burst-rate=512k pcq-burst-threshold=256k \ pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \ pcq-rate=384k pcq-src-address6-mask=64

Queue simple

/queue simple 
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=upload \
    disabled=no interface=ether2 limit-at=128k/0 max-limit=512k/0 \
    name=qs-up-total packet-marks="" parent=none priority=8 \
    queue=q.ty.upload/default-small target-addresses="" \
    total-queue=default-small 
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/0 max-limit=512k/2M \
    name=qs-ds-total packet-marks="" parent=none priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small 
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s \
    direction=download disabled=no interface=ether2 limit-at=0/384k \
    max-limit=0/512k name=qs.game packet-marks=pack.games parent=qs-ds-total \
    priority=6 queue=default-small/q.ty.game target-addresses="" \
    total-queue=default-small 
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small 
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/0 max-limit=0/1M name=qs.all \
    packet-marks= pack.all parent=qs-non-game priority=7 \
    queue=default-small/q.ty.all target-addresses="" total-queue=default-small 
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/0 max-limit=0/1M name=qs.heavy \
    packet-marks=pack.heavy parent=qs-non-game priority=8 \
    queue=default-small/q.ty.heavy target-addresses="" \
    total-queue=default-small

Cara menambahkan port game

temukan dulu port dan pastikan ip tujuan termasuk dalam list nice lewat torch masuk terminal ketik

/ip fi ma 
add copy-from=1 protocol={jenis protocol} dst-port={port games} comment=nama-games .. 

dst utamakan saja game-online yang terinstall di client

Read 5755 times Last modified on 21 Jan 2014, 1:52 PM
Tidar Tanjung

I'm a routing engineer. Trust me, I will show the best path for you.

8 comments

  • Comment Link ragdoll rumble 11 Mar 2016, 12:56 AM posted by ragdoll rumble

    Good info. Lucky me I reach on your website by accident, I bookmarked it.

  • Comment Link nart.time 19 Aug 2015, 5:45 PM posted by nart.time

    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small

    MAAF OOT yg 512K Maksutnya gimana ya? kan max nya 1538k maaf newby

    TRus yg ini mohon di betulkan
    /queue type
    add kind=pcq name=q.ty.upload pcq-burst-rate=256k pcq-burst-threshold=128k \
    pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=96k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.heavy pcq-burst-rate=512k pcq-burst-threshold=384k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=256k pcq-src-address6-mask=64 add kind=pcq name=q.ty.game \
    pcq-burst-rate=384k pcq-burst-threshold=256k pcq-burst-time=16s pcq \
    classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=128k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.all pcq-burst-rate=512k pcq-burst-threshold=256k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=384k pcq-src-address6-mask=64

  • Comment Link nart.time 19 Aug 2015, 5:44 PM posted by nart.time

    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small

    MAAF OOT yg 512K Maksutnya gimana ya? kan max nya 1538k maaf newby

    TRus yg ini mohon di betulkan
    /queue type
    add kind=pcq name=q.ty.upload pcq-burst-rate=256k pcq-burst-threshold=128k \
    pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=96k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.heavy pcq-burst-rate=512k pcq-burst-threshold=384k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=256k pcq-src-address6-mask=64 add kind=pcq name=q.ty.game \
    pcq-burst-rate=384k pcq-burst-threshold=256k pcq-burst-time=16s pcq \
    classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=128k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.all pcq-burst-rate=512k pcq-burst-threshold=256k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=384k pcq-src-address6-mask=64

  • Comment Link nart.time 19 Aug 2015, 5:44 PM posted by nart.time

    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small

    MAAF OOT yg 512K Maksutnya gimana ya? kan max nya 1538k maaf newby

    TRus yg ini mohon di betulkan
    /queue type
    add kind=pcq name=q.ty.upload pcq-burst-rate=256k pcq-burst-threshold=128k \
    pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=96k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.heavy pcq-burst-rate=512k pcq-burst-threshold=384k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=256k pcq-src-address6-mask=64 add kind=pcq name=q.ty.game \
    pcq-burst-rate=384k pcq-burst-threshold=256k pcq-burst-time=16s pcq \
    classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=128k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.all pcq-burst-rate=512k pcq-burst-threshold=256k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=384k pcq-src-address6-mask=64

  • Comment Link nart.time 19 Aug 2015, 5:44 PM posted by nart.time

    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small

    MAAF OOT yg 512K Maksutnya gimana ya? kan max nya 1538k maaf newby

    TRus yg ini mohon di betulkan
    /queue type
    add kind=pcq name=q.ty.upload pcq-burst-rate=256k pcq-burst-threshold=128k \
    pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=96k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.heavy pcq-burst-rate=512k pcq-burst-threshold=384k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=256k pcq-src-address6-mask=64 add kind=pcq name=q.ty.game \
    pcq-burst-rate=384k pcq-burst-threshold=256k pcq-burst-time=16s pcq \
    classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=128k \
    pcq-src-address6-mask=64
    add kind=pcq name=q.ty.all pcq-burst-rate=512k pcq-burst-threshold=256k \
    pcq-burst-time=16s pcq-classifier=dst-address pcq-dst-address6-mask=64 \
    pcq-rate=384k pcq-src-address6-mask=64

  • Comment Link nart.time 19 Aug 2015, 5:43 PM posted by nart.time

    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small

    MAAF OOT yg 512K Maksutnya gimana ya? kan max nya 1538k maaf newby

  • Comment Link nart.time 19 Aug 2015, 5:43 PM posted by nart.time

    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small

    MAAF OOT yg 512K Maksutnya gimana ya? kan max nya 1538k maaf newby

  • Comment Link nart.time 19 Aug 2015, 5:43 PM posted by nart.time

    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=download \
    disabled=no interface=ether2 limit-at=0/512k max-limit=0/1536k \
    name=qs-non-game packet-marks="" parent=qs-ds-total priority=8 \
    queue=default-small/default-small target-addresses="" \
    total-queue=default-small

    MAAF OOT yg 512K Maksutnya gimana ya? kan max nya 1538k maaf newby

Leave a comment

Make sure you enter all the required information, indicated by an asterisk (*). HTML code is not allowed.

Positive SSL