Call Us: (+62).817.410.4747
Log in Register

Login to your account

Username *
Password *
Remember Me

Create an account

Fields marked with an asterisk (*) are required.
Name *
Username *
Password *
Verify password *
Email *
Verify email *
Captcha *

6 queue simple untuk game, browsing, donwload v.6

Dalam versi 6 kali ini, tidak berbeda jauh dengan versi sebelumnya, rule di queue simple tetap 6. hanya ada sedikit perbedaan karena satu rule akan digunakan untuk proxy-HIT. Jadi dari 6 rule tersebut:

  • 1 untuk proxy-HIT
  • 1 sebagai parent total bandwidth yang diberikan ISP,
  • 1 untuk traffic game dan sebagai child dari total bandwidth,
  • 1 sebagai parent non-game dan child dari total bandwidth,
  • 1 untuk traffic all traffic non-games,
  • 1 untuk traffic heavy traffic non games

Syarat jaringan dan setup.

Syarat jaringan dan setup masih mengacu pada artikel sebelumnya.

Kondisi jaringan *bandingan dengen tutorial sebelumnya

  • bandwidth down/up 2mbps/512kbps
  • dipakai kurang lebih 25 pc, dengan ip router 192.168.88.1/27,
  • nama interface untuk lan ethernet=ether2 (perhatikan bagian ini karena digunakan di queue simple)
  • nama interface untuk proxy ethernet=ether3 (perhatikan bagian ini)
  • alokasi game sekitar 512mbps/256k
  • alokasi non game (browsing, download, streaming) sisanya..
  • menggunakan script nice
  • DENGAN proxy nilai DSCP=12
  • tetap menggunakan queue simple
  • tested mikrotik ROS 6.5
  • termasuk game PB, Lost Saga, AyoDance

script nice (modifikasi dari mikrotik.co.id)

/system scheduler
add name=scr-nice policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api source=":if ([:le\
    n [/file find name=nice.rsc]] > 0) do={/file remove nice.rsc } ;/tool fetch url=http://\
    ixp.mikrotik.co.id/download/nice.rsc ;/import nice.rsc"

Mangle

/ip firewall mangle
add action=mark-connection chain=forward comment="bandwidth game // lostsaga" \
    dst-address-list=nice dst-port=14009-14010 new-connection-mark=conn-games \
    protocol=tcp
add action=mark-connection chain=forward dst-address-list=nice dst-port=\
    14009-14026 new-connection-mark=conn-games protocol=udp
add action=mark-connection chain=forward comment=audi dst-address-list=nice \
    dst-port=18901-18910 new-connection-mark=conn-games protocol=tcp
add action=mark-connection chain=forward comment=PB dst-address-list=nice \
    dst-port=39190 new-connection-mark=conn-games protocol=tcp
add action=mark-connection chain=forward dst-address-list=nice dst-port=\
    40000-40010 new-connection-mark=conn-games protocol=udp
add action=mark-packet chain=forward connection-mark=conn-games \
    new-packet-mark=game-packet passthrough=no
add action=mark-connection chain=forward comment="bandwidth management" \
    connection-mark=!heavy_traffic_conn new-connection-mark=all_conn \
    src-address=192.168.88.0/27
add action=mark-connection chain=forward connection-bytes=256000-0 \
    connection-mark=all_conn connection-rate=100k-100M new-connection-mark=\
    heavy_traffic_conn protocol=tcp
add action=mark-connection chain=forward connection-bytes=256000-0 \
    connection-mark=all_conn connection-rate=100k-100M new-connection-mark=\
    heavy_traffic_conn protocol=udp
add action=mark-packet chain=forward connection-mark=all_conn new-packet-mark=\
    all-packet passthrough=no
add action=mark-packet chain=forward connection-mark=heavy_traffic_conn \
    new-packet-mark=heavy-packet passthrough=no
add action=mark-connection chain=postrouting comment="proxy HIT" dscp=12 \
    new-connection-mark=proxy-hit-conn
add action=mark-packet chain=postrouting connection-mark=proxy-hit-conn \
    new-packet-mark=proxy-hit passthrough=no

Queue type

/queue type
add kind=pcq name=pcq_HIT pcq-classifier=dst-address pcq-rate=10M
add kind=pcq name=192_pcq_dst pcq-classifier=dst-address pcq-rate=192k
add kind=pcq name=256_pcq_dst pcq-classifier=dst-address pcq-rate=256k
add kind=pcq name=512_pcq_dst pcq-classifier=dst-address pcq-rate=512k
add kind=pcq name=384_pcq_dst pcq-classifier=dst-address pcq-rate=384k
add kind=pcq name=96_pcq_src pcq-classifier=src-address pcq-rate=96k

Queue simple

/queue simple
add max-limit=20M/20M name=qs.0.HIT packet-marks=proxy-hit queue=\
    default-small/pcq_HIT target=192.168.88.0/27
add max-limit=512k/2M name=qs.1.parent target=192.168.88.0/27
add limit-at=256k/512k max-limit=512k/1M name=1.qs.game packet-marks=\
    game-packet parent=qs.1.parent priority=3/3 queue=\
    pcq-upload-default/256_pcq_dst target=192.168.88.0/27 total-priority=3 \
    total-queue=ethernet-default
add limit-at=64k/0 max-limit=256k/1536k name=2.qs.non.games parent=qs.1.parent \
    target=192.168.88.0/27
add limit-at=64k/384k max-limit=256k/1M name=1.qs.normal packet-marks=\
    all-packet parent=2.qs.non.games priority=7/7 queue=96_pcq_src/384_pcq_dst \
    target=192.168.88.0/27 total-priority=7
add limit-at=64k/128k max-limit=256k/1536k name=2.qs.heavy packet-marks=\
    heavy-packet parent=2.qs.non.games queue=96_pcq_src/512_pcq_dst target=\
    192.168.88.0/27

Cara menambahkan port game

temukan dulu port dan pastikan ip tujuan termasuk dalam list nice lewat torch masuk terminal ketik..

/ip fi ma 
add copy-from=1 protocol={jenis protocol} dst-port={port games} comment=nama-games ..
dst utamakan saja game-online yang terinstall di client
Read 16987 times Last modified on 21 Jan 2014, 1:55 PM
Tidar Tanjung

I'm a routing engineer. Trust me, I will show the best path for you.

7 comments

  • Comment Link dhitya 23 Apr 2015, 6:45 PM posted by dhitya

    semisal bw donw 7mbps dan up 4mbps
    gmna ya gan??

  • Comment Link dhitya 23 Apr 2015, 6:45 PM posted by dhitya

    semisal bw donw 7mbps dan up 4mbps
    gmna ya gan??

  • Comment Link Bayu 08 Aug 2014, 8:40 PM posted by Bayu

    nice tutor..
    sekalian mau tanya kalo gak pake proxy apa cuma dengan disable rule proxy di mangle n queue simple?

    btw proxy nya internal ato eksternal ini?
    Thanks

  • Comment Link Bayu 08 Aug 2014, 8:39 PM posted by Bayu

    nice tutor..
    sekalian mau tanya kalo gak pake proxy apa cuma dengan disable rule proxy di mangle n queue simple?

    btw proxy nya internal ato eksternal ini?
    Thanks

  • Comment Link someone 31 May 2014, 5:06 PM posted by someone

    kalau b/w nya d=512kbps u=150kbps gmna? bisa kasi contohnya sebab msh bingung pembagiannya,maklum msh newbee thanks

  • Comment Link Tidar Tanjung 04 Mar 2014, 1:07 PM posted by Tidar Tanjung

    @yudi

    itu proxy terpisah

  • Comment Link Yudi Nirwana 03 Mar 2014, 9:28 PM posted by Yudi Nirwana

    wah mantap neh tutornya... tp masih pengen tanya". itu Proxy'nya apakah menggunakan proxy bawaan mikrotik/webproxy atau terpisah sendiri ya ?

    Terima Kasih.

Leave a comment

Make sure you enter all the required information, indicated by an asterisk (*). HTML code is not allowed.

Positive SSL